Aug, 20 2009

Snow Leopard compatibility for Posterino

A new cutting-edge version of Posterino is available that improves compatibility with the upcoming release of Mac OS X 10.6 “Snow Leopard”.

If you like to give it a try, use the automatic software update build into Posterino. Choose “Software Update…” from the “Posterino” menu. Don’t forget to watch for “Cutting-Edge” releases (“Posterino” > “Preferences” > “Software Update”). Or just use the link below to download Posterino:

Download Posterino Version 1.5.1 (872)

If you find any problems with this version of Posterino we really appreciate your feedback.

Leave a Reply

Your email address will not be published. Required fields are marked *